[Plugins-writers] Problems accessing Windows registry (XP SP2 only)

From: mailing lists (thelists@private)
Date: Wed Nov 10 2004 - 09:00:42 PST


I've run into a problem gathering information from the registry of a
Windows XP machine.  The machine (really machines) in question is at
SP2 + current patches.  I'm using basically the same code that was
given from my post earlier in September, which has worked without
fault on every machine I've tested it prior to this.

To recap, I'm running this script to return a registry value either as
part of a full-blown scan through the client, or with the nasl utility
and obtaining the same results.  When run against any windows 2000
machine (with proper permissions), it returns the expected value,
however, when run against a Win XP SP2 machine, it returns nothing.

(As an aside, I've run this against another XP SP2 machine and am
getting an array of messages such as "get_array_elem: variable reply
is an integer" and "ord() usage : ord(char)".  The script does not in
itself directly make use of the ord function.)

Is this a known occurrence?  Could it perhaps have anything to do with
the method in which the registry is being invoked?  Am I missing
something utterly obvious here?  Any information would be helpful.

I've tried this with nessus versions 2.0.10 and 2.0.12 with the
current plugin set.

Plugins-writers mailing list

This archive was generated by hypermail 2.1.3 : Wed Nov 10 2004 - 09:14:17 PST