Re: [Plugins-writers] Scripting local security checks

From: David Jacoby (dj@private)
Date: Wed Dec 08 2004 - 03:25:46 PST

Renaud Deraison wrote:

> Please upgrade your by running nessus-update-plugins (or
> doing a fresh cvs update). ssh_cmd does not return -1 any more and
> various issues have been fixed since.

Well i used the nessus-update-plugins script and updated my script-database, but
it didnt get better =), It solved the issue that ssh_cmd returned -1 but now i
have another issue, instead of waiting untill my ssh_cmd is done it just closes
the connection and the cmd is executed in the background on the server. When the 
report is done it says that my script didnt get executed but its still running
on the server im testing. I tried with different commands but if it takes more
than like 15 seconds for the script to get an output the connection is closed.

For example

buf = ssh_cmd(socket:sock,cmd:"cat /etc/passwd"); 			<- Works Fine
buf = ssh_cmd(socket:sock,cmd:"find / -name FIND_ME 2>/dev/null");	<- Does NOT work.

I also tried to apply an timeout on 200 but didnt work either. Am i missing anytning?
My NASL skills are very novice.

Best regards
David Jacoby
Research & Development
Outpost24 AB

Plugins-writers mailing list

This archive was generated by hypermail 2.1.3 : Wed Dec 08 2004 - 02:27:47 PST